Update from 2019-03-15 16:30 UTC to 2019-03-15 18:30 UTC

Scheduled Maintenance Customer Services Knowledgebase Support Tickets Halls Group (UK) Sites & Services Billing Services Client Area Halls Hosting - Website
2 hours

Update

Monitoring

We are currently updating our website, this shouldn’t take no more than 3 hours.

Support tickets will be answered, but it may take longer for us to reply. This is due to updating the backend systems.

Please do keep checking back to this website to find out our progress.

Mar 15th, 2019 13:34 UTC